• Welcome to the new Distech Automation Forum!
  • Feel free to post questions, comments, and feedback.
  • Ask us anything!
Hello There, Guest! Login Register


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post processor script development (S3D/Prusa Slic3r support)
#91
Hmm, is 4.0.1 a recent update or the one that was released during summer? 4.x should supported, bit if there's a new version, something might've changed. Please send me the gcode so I can check whats causing the problem.
 
Reply
#92
4.0.1 doesn't appear in the "check for updates" dialog box. You have to download from their site.

The same gcode works in v0.13?

Link to file: Dropbox link

J.
Jay's 3D Adventure
Twitter:
twitter.com/Jays3DAdventure
Instagram:
instagram.com/jays_3d_adventure/
YouTube:
t.co/GesyvQVrZP
 
Reply
#93
Hmm, an update but no notification? Weird.
Anyhow, I fixed the bug and it should slice ok now. Both cfgfiles and master branch.
 
Reply
#94
Can't recall if you answered this before.. but anyway of getting a raft or wide skirt on the tower?  I've had several failed prints now where the main print item is sticking nicely, but the increasingly tall and narrow tower topples over. Not helped by the fact the first layers appear (I think) to be a sparse cross hatch!
 
Reply
#95
Well there's an issue open currently which would remove the raft in case there's tool change at first layer. Not working on it.
Currently raft is the default first layer print. Brim can be widened to match the print settings, but not working on it currently.
Current master branch has option to make the raft lines fatter, in Advanced-options.
 
Reply
#96
(12-26-2017, 06:10 PM)spegelius Wrote: Well there's an issue open currently which would remove the raft in case there's tool change at first layer. Not working on it.
Currently raft is the default first layer print. Brim can be widened to match the print settings, but not working on it currently.
Current master branch has option to make the raft lines fatter, in Advanced-options.

Yeah I tried the max setting for raft thickness, still no joy.
I dont think the tower will ever work with my PLA on PrintBite bed. Maybe something else is going on but the main part sticks great, your tower doesnt, it just needs that wide raft (or skirt) I put on my prints.

Also, any chance of customisable tower shapes? I suspect a circle would adhere far better than the rectangle base!
 
Reply
#97
(12-27-2017, 10:17 AM)kodachrome Wrote:
(12-26-2017, 06:10 PM)spegelius Wrote: Well there's an issue open currently which would remove the raft in case there's tool change at first layer. Not working on it.
Currently raft is the default first layer print. Brim can be widened to match the print settings, but not working on it currently.
Current master branch has option to make the raft lines fatter, in Advanced-options.

Yeah I tried the max setting for raft thickness, still no joy.
I dont think the tower will ever work with my PLA on PrintBite bed. Maybe something else is going on but the main part sticks great, your tower doesnt, it just needs that wide raft (or skirt) I put on my prints.

Also, any chance of customisable tower shapes? I suspect a circle would adhere far better than the rectangle base!

I have Printbite also, it worked fine with PLA at first but now I have to use glue stick to get it to stick properly. On two different printers. I don't have time to look into it more, I just tried glue stick and seems to fix the problem.

To change the shape of the tower, you could try cfgfiles branch (https://github.com/spegelius/filaswitch/tree/cfgfiles) and make your own configuration by copying one of the original configs to new name. Edit the config:
- prepurge.sweep.length: 30
- prepurge.sweep.count: 7

Also add more purge lines in GUI advanced options. This should make the tower more cube like.
Circle might be possible, but will require lots more effort and not going to be a priority for me.
 
Reply
#98
speglius, the post processor does not take into account a z-offset in s3d.  Can you please add that soon?
 
Reply
#99
spegius, I have my z offset = 1.54 in simplify3d for my probe, but your post processor does not recognize this z offset and tries to start printing the raft at z =0 .5

; TOWER RAFT START
G1 Z0.7540 F180; z-hop
G1 X122.600 Y211.146 F12000; move to raft zone
G1 Z0.5 F180; move z close

Everytime I run my gcode through your post processor and try to print it the hot end crashes into the bed.  Any help is appreciated.
 
Reply
There's some code already done but last time I tested, S3D had some bugs about what the offset really is (setting it to 0.2 for example resulted in z 0.22 or so... can't remember all the details).

Are you using S3d 4.0.0 or 4.0.1?

Edit: personally I tune my z-offset with Marlin's M851 command and store it to EEPROM as I use 3 different slicers and I want to keep that setting in one place. But Filaswitch should recognize that value so I'll fix it, hopefully have some time today.
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)